GRE 터널모드
2024. 9. 3. 17:39
728x90
[ ESP Header vs. GRE Header ]
*ESP Header 를 앞에 붙이면 암호화됨 -> Original IP를 알 수 없어서 라우팅 문제가 발생하므로 New IP Header를 붙임
*GRE Header 를 앞에 붙이면 암호화 안됨 -> GRE Tunnel 을 통과하기 위해 New IP Header를 붙임
- 물리적인 GRE Tunnel 을 통해서 두 라우터간 직접 통신하듯이 구성할 수 있음 (R1, R4 두 개의 라우터만 있으면 됨)
- 물리적 : R1 -> R2 -> R3 -> R4 를 거쳐 통신하는 형태
- 논리적 : R2, R3 건너뛰고 R1 -> R4 로 직접 통신하는 형태
[ GRE 통신 기법 ]
*GRE : VPN 같지만 VPN은 아닌 기법
- interface loopback 0 : 논리적인 연결 설정 - 인터페이스 진입 (no shutdown 필요 없음)
- isis : 물리적인 연결을 설정해줌 (no shutdown 명령어 필요)
[ 01. 논리적인 연결 (isis) ]
================ <R1> ================
configure terminal
interface serial 1/1
ip address 192.168.12.1 255.255.255.0
ip router isis
no shutdown
exit
router isis
net 49.0012.1111.1111.1111.00
metric-style wide
================ <R2> ================
configure terminal
interface serial 1/2
ip address 192.168.12.2 255.255.255.0
ip router isis
no shutdown
exit
interface serial 1/1
ip address 192.168.23.1 255.255.255.0
ip router isis
no shutdown
exit
router isis
net 49.0023.2222.2222.2222.00
metric-style wide
================ <R3> ================
configure terminal
interface serial 1/2
ip address 192.168.23.2 255.255.255.0
ip router isis
no shutdown
exit
interface serial 1/1
ip address 192.168.34.1 255.255.255.0
ip router isis
no shutdown
exit
router isis
net 49.0034.3333.3333.3333.00
metric-style wide
================ <R4> ================
configure terminal
interface serial 1/2
ip address 192.168.34.2 255.255.255.0
ip router isis
no shutdown
exit
router isis
net 49.0041.4444.4444.4444.00
metric-style wide
================ < 설정 확인 > ================
# ISIS 라우팅 테이블 확인
show ip route isis
# 인터페이스 상태 확인
show ip interface brief
[ 02. 물리적인 연결 ]
인터페이스 loopback 에 터널 (R1, R4 연결) 등록
================ <R1> ================
interface tunnel 14
ip address 172.16.14.1 255.255.255.0
tunnel mode gre ip
tunnel source serial 1/1
tunnel destination 192.168.34.2
exit
router rip
version 2
no auto-summary
network 172.16.1.0 # loopback interface
network 172.16.14.0 # tunnel 14 interface
end
================ <R4> ================
interface tunnel 14
ip address 172.16.14.2 255.255.255.0
tunnel mode gre ip
tunnel source serial 1/2
tunnel destination 192.168.12.1
exit
router rip
version 2
no auto-summary
network 172.16.4.0 # loopback interface
network 172.16.14.0 # tunnel 14 interface
end
================ < 설정 확인 > ================
# RIP 라우팅 테이블 확인
show ip route rip
# 인터페이스 상태 확인
show ip interface brief
# GRE 인터페이스 확인
show interfaces tunnel 14
728x90
'Unix Linux' 카테고리의 다른 글
라우팅 설정 및 AH-ESP 터널모드 구성 (1) | 2024.09.03 |
---|---|
alias 등록 (0) | 2024.08.27 |
Unix/Linux SSL 설정 방법 (Debian) (0) | 2024.08.20 |